KB Article ID: 10203
Product: | Installation |
Product Version: | 6.0.0.0 |
SharePoint Version: | 2010 SP1 |
Details:
During an Agent installation on a WFE/SQL, after inputting the Control Server name and port and clicking Next, the following error message is generated: Manager cannot connect to agent. This indicates that the Agent to Manager connection is fine, but Manager to Agent is not.
SYMPTOMS:
Despite no firewalls blocking the ports, all permissions work properly, and servers can be pinged both ways, the test still fails during Agent install.
CAUSE:
Service called Net. Tcp Port Sharing Service must be running in order for the Agent installation to complete.
SOLUTION:
Check if Net. Tcp Port Sharing Service is stopped or disabled. Enable and run the installation again.